No auto idle on powerweld 303
RSS | Subscribe | Contact Us | Advertise | About Us
Results 1 to 9 of 9
  1. #1

    No auto idle on powerweld 303

    Hi, I'm new here, my name is J-F and I'm a farm/truck mechanic. Just bought a hobart powerweld 303 yesterday, and here is my problem. the auto-idle do not work. By the way is my first gas-powered welder, so i don't know much about them... The machine have the auto switch, lill black module on the right side, some kind of vacuum solenoid witch one red wire is connected to a small actuator on the carb. The governor is connected to the carb. via the rod. Now I think i'm missing a part, because I do have a small chain attached to the carb. linkage to a small lever on top of the governor, but nothing connected to...
    The guy put a throttle cable to control the engine speed witch do not allow the governor to work properly. I know the proper engine speed is 1800 RPM, but with no governor (and RPM gauge) it will be very hard to control.
    My question is : Do anybody have a picture of the right side of the engine, or some sorte of shop Manuel, or even an idea of what is missing.
    If the engine turn to fast or not enough, do I can cause any damage to the welder?

    Thanks,
    J.F

  2. #2
    Join Date
    Nov 2006
    Posts
    5,748

    Re: No auto idle on powerweld 303

    Welcome Jfsanterre,

    You definitely should not over-speed the generator.
    Doesn't your Hobart have a Ford six with a belt-driven governor?
    If so, manually setting the governor control to "full fuel" shouldn't allow the engine to over-speed.

    For a Hobart manual source, check out reply #21 here:
    http://weldingweb.com/showthread.php?t=28906

    Good Luck

  3. #3

    Re: No auto idle on powerweld 303

    The welder have the ford 6 cyl. engine with the belt governor. The carburetor have been replaced recently with a Motocraft one... I'll look a the tag # lather make sure it is the good one. The thing is, the throttle cable is attached directly to the carb. linkage and not the governor, so the governor work against the cable. I may try to install the cable to the governor today.

    Other than that the welder is in very good shape with only 600 Hrs (real???). It do have the pole inverter in front also.

    The welder work well and so the AC outlet. The way I set my engine speed was by watching the AC output with a voltmeter, until I hit 115 V. I would like to fix the auto-idle, less pain in the but...

    Here an other newbie question... the large well set the amp range, and the small (fine tuning one) set the voltage??

    Thanks,
    J.F.

  4. #4

    Re: No auto idle on powerweld 303

    Here is a few pictures, if anyone saw the problem or a missing component.
    Attached Images Attached Images    

  5. #5

    Re: No auto idle on powerweld 303

    First picture, do this is the fast idle solenoid?
    Second, I guest this is the fast idle control module?
    Third, the machine itself.
    Attached Images Attached Images    

  6. #6

    Re: No auto idle on powerweld 303

    found out some problems... It have no vacuum actuator to pull back the throttle linkage, it was remove because the little black box have a blown diode, who let ground go through and not allowing vacuum realest at solenoid. I installed a choke pull off instead of the vacuum actuator and fabricate a linkage. I'll get a new diode tomorrow and hope it will work for me.

  7. #7
    Join Date
    Mar 2004
    Location
    B.C. Canada
    Posts
    2,388

    Re: No auto idle on powerweld 303

    When you download the Hobart manual for your machine you should find a spec sheet with the amp volt curve. The large dial selects the range and the small rheostat fine tunes within the range. The ranges overlap. Generally for out of position work you would select a lower range and fine tune to the top end. For flat and horizontal with iron powder rods you would select a higher range and fine adjust near the bottom of that range.

  8. #8
    Join Date
    Nov 2006
    Posts
    5,748

    Re: No auto idle on powerweld 303

    Greetings Jfsanterre,
    Your welder looks like it's in great condition.

    Quote Originally Posted by jfsanterre View Post
    ...My question is : Do anybody have a picture of the right side of the engine...
    Like so?
    Attachment 32039

    I love the little Ford sixes; they were one tough engine.

    Quote Originally Posted by jfsanterre View Post
    First picture, do this is the fast idle solenoid?
    Second, I guest this is the fast idle control module?...
    First picture - Yes, that's the idle module.

    Second picture - I'm not sure what it is, but for sure it's not a speed control, since it could not adjust for load. Maybe that's a curb idle solenoid; probably just holds basic idle when the key is on, and then drops out at shut-down, to allow the throttle plate to close completely, to prevent run-on. Ford probably shipped the engine with solenoid, so Hobart probably stuffed the wire somewhere in the harness.

    I'm not sure if a choke pull-off will have enough power to handle the fast idle.
    The original "pancake" had about a 4" diameter vacuum diaphragm; that's a lot more surface area than a typical choke pull-off.

    Since you're trying car parts, maybe you could use something like a vacuum-type cruise-control servo, to pull the linkage.

    Something like this one:
    Attachment 32040

    I noticed your control is missing the label.
    Pin-out should be the same as this one, but I'm not sure.
    Attachment 32041

    Good Luck
    Last edited by denrep; 10-19-2010 at 11:36 PM.

  9. #9

    Re: No auto idle on powerweld 303

    Thanks to you two for the reply.
    I guess the original vacuum actuator is way much bigger then the choke pull off. The cruise control actuator is a good idea, didn't think about it.
    Thanks for the picture of the box. For some reasons, mine was on the inside of the cover. Got the box open and it contain a very basic circuit board with only few resistors, diodes and a transistor. Test all component and find out that one of the diode is burnt and allow ground to go through all the time, that keep the vacuum solenoid always energize. If I got time this week I'll get one diode and try for the best...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
RSS | Home | Penton Media | Contact Us | Subscribe | For Advertisers | Terms of Use | Privacy Statement