PowCon 200SM
RSS | Subscribe | Contact Us | Advertise | About Us
Results 1 to 2 of 2

Thread: PowCon 200SM

  1. #1

    PowCon 200SM

    We acquired this PowCon 200SM recently. The first day we had it, the machine ran well. Then, the MIG gun started cutting out. Now, it may feed wire and gas every 10th or 15th trigger pull. When it does work, it works well. The inch and purge buttons work well. The process selector switch was shot, so we replaced it with the identical part from the original manufacturer. Unfortunately, it didn't fix the problem.
    The previous owner had it stashed away in his shop unused for a few years.
    Do we need to replace the MIG gun? Or is it an issue with the feeder? Any input would be great.

  2. #2
    Join Date
    Oct 2007
    Location
    Yuba City, CA
    Posts
    1,704

    Re: PowCon 200SM

    simple things first: check that loose, 2 connector plug coming off the gun, check for circuit continuity when
    gun trigger's pulled.
    That plug can easily get slightly loose and no gun workee.
    Disassemble torch handle and check those plastic parts and brass contacts for workee.
    Bypass gun wiring and see if gas and wire feed, jumpering the machine connections for that loose,
    2 connector plug.

    I've got a powcon 300SMT, since new-1989.
    Blackbird

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
RSS | Home | Penton Media | Contact Us | Subscribe | For Advertisers | Terms of Use | Privacy Statement