Lincoln sp 100 problems
RSS | Subscribe | Contact Us | Advertise | About Us
Results 1 to 6 of 6
  1. #1

    Lincoln sp 100 problems

    Hey guys, just looking for a little help for my little Lincoln. I just bought it thinking it was working but its not. It acts like a car with a dead battery. Turn it on and the fans run, pull the trigger and it clicks and sometimes the spool turns like a quarter turn and a very weak spark. I can't see anything loose, corroded, or burnt. Just wondering if anybody had a similar situation before I stick more money into it than its worth. Thanx for listening and any advice is appreciated.

  2. #2
    Join Date
    Jan 2014
    Location
    Tiverton, Ontario, Canada
    Posts
    14

    Re: Lincoln sp 100 problems

    Quote Originally Posted by hungrybare View Post
    Hey guys, just looking for a little help for my little Lincoln. I just bought it thinking it was working but its not. It acts like a car with a dead battery. Turn it on and the fans run, pull the trigger and it clicks and sometimes the spool turns like a quarter turn and a very weak spark. I can't see anything loose, corroded, or burnt. Just wondering if anybody had a similar situation before I stick more money into it than its worth. Thanx for listening and any advice is appreciated.
    I had a lot of problems with the used one I picked up when I first got it. Sounds like your spool may be wound tight like mine. There is a set screw behind the screw holding the wire spool on that probably needs to be adjusted so the wire will turn freely. Took a lot of reading to figure this out. I think if you read the manual it covers this, but mine did not come with one. The local welding supply store had no idea when I asked them.

  3. #3

    Re: Lincoln sp 100 problems

    I did check for any friction in the spool, took the liner out and there is no kinks, and the wire moves back and forth through the liner smooth as silk. The thing is I don't have any arc hardly at all just a little when the spool moves a fraction of a turn.

  4. #4
    Join Date
    Oct 2009
    Location
    Austin TX
    Posts
    797

    Re: Lincoln sp 100 problems

    I had a similar problem with my Lincoln. Turned out that one of the knobs (wire speed or voltage) was just a little out of position. Try moving the knobs around and see if they make better contact.
    Miller Syncrowave 350
    Millermatic 252/ 30A spoolgun
    Miller Bobcat 225g w/ 3545 spoolgun
    Lincoln PowerArc4000
    Lincoln 175 Mig
    Lincoln 135 Mig
    Everlast 250EX Tig
    Century ac/dc 230 amp stick
    Victor O/A
    Hypertherm 1000 plasma

  5. #5
    Join Date
    Jan 2011
    Location
    Fairview Park.,Ohio
    Posts
    76

    Re: Lincoln sp 100 problems

    You can download the SP-100 operator's manual here:
    https://www.lincolnelectric.com/asse...oln3/IM366.pdf
    The schematic is on page 26.

    You can also download the SP-100 service manual here:
    https://www.a-zrental.com/instruct/sp100.pdf
    Last edited by ltvtom; 05-14-2018 at 03:10 AM.

  6. #6

    Re: Lincoln sp 100 problems

    Quote Originally Posted by ltvtom View Post
    You can download the SP-100 operator's manual here:
    https://www.lincolnelectric.com/asse...oln3/IM366.pdf
    The schematic is on page 26.

    You can also download the SP-100 service manual here:
    https://www.a-zrental.com/instruct/sp100.pdf
    Thanx guys, Ill see if I can figure it out

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
RSS | Home | Penton Media | Contact Us | Subscribe | For Advertisers | Terms of Use | Privacy Statement