Lincoln Mig Pak 10 No Power on
RSS | Subscribe | Contact Us | Advertise | About Us
Results 1 to 2 of 2
  1. #1

    Lincoln Mig Pak 10 No Power on

    Hello all you wonderful welders out there. This is my first post and I joined here specifically to learn more about welding.
    I'm just a hobbyist and have limited welding experience to welding up some exhaust on an old car I had.

    I picked up recently a Lincoln Mig Pak 10 Nascar welder used and it worked for about 10 mins in total, I was able to confirm the wire feed and gun actuated properly. Arc was decent etc.

    This was approximately 3 months ago. Recently move the unit outside and no the unit will not power on, no fan, no buzz, no wire feed etc.

    I have confirmed:
    Power to the outlet(used 3 different power tools).
    Power into the unit
    power in and out of the unit breaker(and breaker is not tripped)
    Power in/out of the on/off switch

    I also tried the unit on 3 different plugs in my house including the original one that I had success on.

    Any ideas of what might be wrong? I know it's hard to diagnosis over the internet but my local service depot wants close to $200 just to look at the machine not including any repairs/parts

  2. #2

    Re: Lincoln Mig Pak 10 No Power on

    Anyone have any ideas? Is there a way to separate the Fan and control module or something along those lines? Is the Fan no kicking on a symptom of failure? as in if the fan doesn't kick on could it cause the welder to not power on? Ie no tell tale buzz

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
RSS | Home | Penton Media | Contact Us | Subscribe | For Advertisers | Terms of Use | Privacy Statement