PDA

View Full Version : Beta-Mig Schematic?



graniteguy
07-11-2018, 09:06 PM
Hello to all, I am in the process of rehabbing a Beta-Mig LF that is suffering from a bad case of previous owner syndrome. There are some wires dangling about inside and I'd like to tidy those up. A copy of the manual came with, but the quality is so bad that the schematic is pretty much unreadable. Does anybody have a legible copy of the wiring diagram? I'd be glad to pay a reasonable fee. Thanks in advance for any help.

labparamour
07-16-2018, 01:09 PM
Not sure if you found a schematic yet.
I have a beta mig 200...not sure of the similarities.
My manual is bare bones with just a few part numbers for gun, etc.
If you can post a pic of the area of your machine, I could probably pull the sides and send a pic of my machine for the area in question.

Darryl

graniteguy
07-24-2018, 07:16 PM
Darryl, I solved the problem by cutting all of the cable ties. I could then determine that the wires went back to a connector for optional modules that could be installed, like a stitch timer. I am unlikely to ever use that, so I just rolled the wires up and strapped 'em to the connector. Problem solved. The only difference between the LF and other B-Ms of the same vintage is the wire feed assembly being in the enclosure. Thanks for your response. The welder works just fine, just had to clean and tighten all of the internal connects and replace the burned out panel jacks on the front.

Poleframer
07-24-2018, 11:50 PM
Might help...Should be your machine less the feeder portion.
https://www.manualslib.com/manual/940260/Hobart-Beta-Mig-200.html#manual

graniteguy
08-09-2018, 05:59 PM
Poleframer, thanks for the link. The schematic is a whole lot more legible. The danglers have all been handled now and I'm on to solving the final issue remaining. The arc surges, almost stutters for a few seconds when starting, then smooths out. I think I might be looking at a filter capacitor problem. Otherwise it's one sweet machine.