Everlast welder gas flow issue
RSS | Subscribe | Contact Us | Advertise | About Us
Results 1 to 2 of 2
  1. #1

    Everlast welder gas flow issue

    Hi all,
    I own an Everlast power I-Tig 200 and it has been working fine until about a week ago when the gas flow for the Tig side of it stopped working. Now it puts out gas for only about a quarter of a second when i press the trigger but then stops putting out gas. when i start the weld i hit the trigger and hear a clicking sound and the aforementioned short gas flow. i pulled apart the welder and found a blown IGBT with the part number FF60UP30DN but other than that i didn't find any visible damage. If someone has any experience with a problem similar to this or knows something about Everlast welders please respond.

  2. #2
    Join Date
    Nov 2008
    Location
    south GA where its hot in summer and cold in winter
    Posts
    4,739

    Re: Everlast welder gas flow issue

    Adam,
    Why haven't you called tech support? They can help you. If the unit is still in warranty or out, they will be able to help you get the part and or a solution to your problem and or get you authorization to ship it back for repair.
    8777559353 ext 207.
    Esab Migmaster 250
    Lincoln SA 200
    Lincoln Ranger 8
    Smith Oxy Fuel setup
    Everlast PowerPlasma 80
    Everlast Power iMIG 160
    Everlast Power iMIG 205
    Everlast Power iMIG 140E
    Everlast PowerARC 300
    Everlast PowerARC 140ST
    Everlast PowerTIG 255EXT

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
RSS | Home | Penton Media | Contact Us | Subscribe | For Advertisers | Terms of Use | Privacy Statement