Trailblazer jump problems
RSS | Subscribe | Contact Us | Advertise | About Us
Results 1 to 7 of 7
  1. #1
    Join Date
    Nov 2014
    Location
    hawaii
    Posts
    15

    Trailblazer jump problems

    I have a trailblazer 302 kohler motor
    Unknowingly jumped a dead batter w charger and blew a board i think.
    I know the volt reg is shot. Also it started welding lees power and then died
    Anyone know of the troubleshooting necessary?

    Perhaps a thread about this?
    Thanks
    Aloha

  2. #2
    Join Date
    Apr 2008
    Location
    NW ON Canada
    Posts
    3,000

    Re: Trailblazer jump problems

    Before you start replacing boards, check all the fuses. Your manual will tell you the fuse locations.
    Jason
    Lincoln Idealarc 250 stick/tig
    Thermal Dynamics Cutmaster 52
    Miller Bobcat 250
    Torchmate CNC table
    Thermal Arc Hefty 2
    Ironworkers Local 720

  3. #3
    Join Date
    Nov 2014
    Location
    hawaii
    Posts
    15

    Re: Trailblazer jump problems

    Tha ks Jason,
    I will do that. It does run,doesnt charge,doesnt weld. Im looking for a troubleshooting guide and or a wiring diagram. Im pretty savy in electronics.
    Was a et in the navy
    Aloha
    Dan

  4. #4
    Join Date
    May 2014
    Location
    Central Wa. state
    Posts
    1,772

    Re: Trailblazer jump problems

    Class... Repeat after me... NEVER turn on the ignition on one of these machines with a battery charger connected and running. Charge the battery, disconnect charger and attempt to start the machine. Sorry OP, but I think you nailed a board or 2. There should be some info down in the Miller forum.

    But on second thought, you may have a blown fuse depending on the charge/start procedure you used. High battery charge voltage is not good for the boards, and immediately forcing the engine to charge a bad/low battery can blow a fuse.
    Last edited by 12V71; 10-08-2018 at 08:57 PM.

  5. #5
    Join Date
    Nov 2014
    Location
    hawaii
    Posts
    15

    Re: Trailblazer jump problems

    Thanks 12 v i never charged the battery with it turned on,sorry. Im a bit sharper than that. I helped do the research on the power supplies on the space shuttle in the 80's(not the chalenger btw)
    Aloha

  6. #6
    Join Date
    May 2014
    Location
    Central Wa. state
    Posts
    1,772

    Re: Trailblazer jump problems

    Quote Originally Posted by starwind View Post
    Thanks 12 v i never charged the battery with it turned on,sorry. Im a bit sharper than that. I helped do the research on the power supplies on the space shuttle in the 80's(not the chalenger btw)
    Aloha
    Get a manual and check all your fuses first. I don't have a manual close by at the moment, but the first fuse I would check is on the engine side of the firewall on the lefthand side looking at the machine from the control end. I think that is "F1".
    Since you mentioned the Space Shuttle, I had to get a FRA Locomotive Engineers licence in 1998, the man that signed me off was named Frank Scobee… He had a son named Dick Scobee. The commander of the final Challenger mission. Frank was very proud of his son. And I am glad I got to spend that time with him.

  7. #7
    Join Date
    Nov 2014
    Location
    hawaii
    Posts
    15

    Re: Trailblazer jump problems

    Both the Scobies are heros in my book
    Dan

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
RSS | Home | Penton Media | Contact Us | Subscribe | For Advertisers | Terms of Use | Privacy Statement