Harbor Freight 62204 plasma cutter sometimes does not fire
RSS | Subscribe | Contact Us | Advertise | About Us
Results 1 to 12 of 12
  1. #1

    Harbor Freight 62204 plasma cutter sometimes does not fire

    I bought a Harbor Freight model 62204 plasma cutter a couple of years ago. It's worked ok until a few months ago when it began to work intermittently. I cut a few items then it won't fire. After several minutes it will fire again. I only cut 1/8 inch steel and not too much at a time. cuts are either one inch long or 8 inches long. I have tried different settings and new consumables. I searched the topic on this site and found some posts, but they appear to be for older model cutters. Any help would be greatly appreciated. I have repaired some circuit boards on other electronics in the past but have no real knowledge of whats what. So pictures go a long way... thanks, paul

  2. #2
    Join Date
    Mar 2011
    Location
    Western Washington
    Posts
    2,707

    Re: Harbor Freight 62204 plasma cutter sometimes does not fire

    Sounds like the consumables.... I know you said tried new ones and still the same issue??? are you sure the new consumables are good/right? are you changing *all* of the parts? also.... you do have good air pressure when this happens right??? and filters/driers are not plugged or partially restricted?

  3. #3
    Join Date
    Mar 2010
    Location
    Delaware
    Posts
    2,718

    Re: Harbor Freight 62204 plasma cutter sometimes does not fire

    Quote Originally Posted by ronsii View Post
    Sounds like the consumables.... I know you said tried new ones and still the same issue??? are you sure the new consumables are good/right? are you changing *all* of the parts? also.... you do have good air pressure when this happens right??? and filters/driers are not plugged or partially restricted?
    Well you covered about most of the items I would have told him to check. But one of the biggest questions is are they original consumables from Italy or Chinese copy's. I hear about this all the time and find they were using cheap consumables sold on ebay or amazon.
    Last edited by mechanic416; 04-10-2019 at 07:28 PM.
    www.georgesplasmacuttershop.com
    Plasma Cutter and Welder Sales and Repairs--Ebay store
    Primeweld dealer and tech support
    Tec.Mo. Dealer Consumables for the PT and IPT torch's

  4. #4

    Re: Harbor Freight 62204 plasma cutter sometimes does not fire

    Quote Originally Posted by mechanic416 View Post
    Well you covered about most of the items I would have told him to check. But one of the biggest questions is are they original consumables from Italy or Chinese copy's. I hear about this all the time and find they were using cheap consumables sold on ebay or amazon.
    I have been using ebay consumables for more than a year. They have been working great. I guess I figured a HF unit would use generic . I was actually using drag tips when it started to act up a few weeks ago. I switched back to some generic regular tips. Still a problem. Sounds like I should order some from Harbor freight.

    I have several water filters including a Motor Guard sub micron filter last. It’s dry.

  5. #5

    Re: Harbor Freight 62204 plasma cutter sometimes does not fire

    Quote Originally Posted by mechanic416 View Post
    Well you covered about most of the items I would have told him to check. But one of the biggest questions is are they original consumables from Italy or Chinese copy's. I hear about this all the time and find they were using cheap consumables sold on ebay or amazon.
    I checked my ebay records and it turns out my drag tips came from your ebay store, so they should not be the problem. I didn’t realize the originals came from Italy.... i think I have one new set left, going to put them in and try it.

  6. #6
    Join Date
    Mar 2010
    Location
    Delaware
    Posts
    2,718

    Re: Harbor Freight 62204 plasma cutter sometimes does not fire

    If you got them from me then they are the right ones. They run at 40 amps and 70 to 75psi. There are 4 parts electrode, swirl ring, tip and retaining cup. Check the little contact pins and make sure then are spring in and out and making contact with the ring on the retaining cup, also check the electrode it should push in then spring out, there should be about 1/8" of movement. If its none of these I would start looking for a air problem.
    www.georgesplasmacuttershop.com
    Plasma Cutter and Welder Sales and Repairs--Ebay store
    Primeweld dealer and tech support
    Tec.Mo. Dealer Consumables for the PT and IPT torch's

  7. #7
    Join Date
    Sep 2011
    Location
    USA
    Posts
    140

    Re: Harbor Freight 62204 plasma cutter sometimes does not fire

    I have the same problem with my plasma cutter, if you look at the end of the electrode and inside at the bottom of the tip I believe you will find it is carboned up. The carbon or black film doesn't allow the electrode to start the ark. I take a small wire bush and clean the electrode tip and inside the cutting tip. This works for awhile and then it needs cleaned again. George I believe is right seems like an air problem. I run my air thru a Motorguard filter also. I would like to know what is causing the contamination in the filtered air. The air filter is connected right at the cutter.
    ________________________________
    Everlast PA140ST
    Everlast PowerPlasma 50
    And no you can't Borrow them

  8. #8
    Join Date
    Mar 2011
    Location
    Western Washington
    Posts
    2,707

    Re: Harbor Freight 62204 plasma cutter sometimes does not fire

    the carbon sounds like yours is moist air??? have you thought about a drier right after the motorguard? how often do you put new filters in? and is your compressor fairly small and putting lots of moisture in or a 60-80+ gallon tank?

  9. #9

    Re: Harbor Freight 62204 plasma cutter sometimes does not fire

    I put in the last new set I got on your site, and it's cutting like a champ right now. I will check out the other items you mention, and order more drag tips and electrodes.... THanks!

    Been running at 35 amps and 80 psi. I am cutting 1/8 inch steel, mostly 4130 but some 1075/80 as well.

    I will try the settings you are recommending on the next batch I cut up.

    I make clam hoes...

  10. #10

    Re: Harbor Freight 62204 plasma cutter sometimes does not fire

    With new tip and electrode from your site, it cut good for about 10 8 inch long cuts in 1/8 inch 4130 steel. After that it continued to work but the misfires started again. when I took it apart the electrode seemed to be stuck in. I pushed on it a few times and it began to pop in and out but not always coming all the way out. does this get any kind of lube or service? or are there parts to replace? It definitely does not snap out all the way some of the time.

  11. #11

    Re: Harbor Freight 62204 plasma cutter sometimes does not fire

    Quote Originally Posted by mechanic416 View Post
    If you got them from me then they are the right ones. They run at 40 amps and 70 to 75psi. There are 4 parts electrode, swirl ring, tip and retaining cup. Check the little contact pins and make sure then are spring in and out and making contact with the ring on the retaining cup, also check the electrode it should push in then spring out, there should be about 1/8" of movement. If its none of these I would start looking for a air problem.
    George,

    This has been very helpful, I changed my setting to 40 amps, re calibrated the air flow. But what what I think may have solved my problem was the 1/8 " movement of the electrode. It seemed to be sticking as each time I took it apart it was stuck in. I worked on it for a while and applied a tiny amount of an oil called deoxit (which is for electrical contacts) where the electrode screws in. Then I just worked it in and out until it was very free. Once again, cutting like a champ... hope it holds up. Also, I may have been over tightening the retaining cup.

    Thanks, Paul

  12. #12
    Join Date
    Mar 2010
    Location
    Delaware
    Posts
    2,718

    Re: Harbor Freight 62204 plasma cutter sometimes does not fire

    A very little silicone grease will work also, that is what is recommend by Tecmo. Over tightening the electrode will cause the plunger to swell and cause it to stick also.
    www.georgesplasmacuttershop.com
    Plasma Cutter and Welder Sales and Repairs--Ebay store
    Primeweld dealer and tech support
    Tec.Mo. Dealer Consumables for the PT and IPT torch's

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
RSS | Home | Penton Media | Contact Us | Subscribe | For Advertisers | Terms of Use | Privacy Statement