SA250 down no or low power output
RSS | Subscribe | Contact Us | Advertise | About Us
Results 1 to 4 of 4
  1. #1
    Join Date
    Apr 2006
    Location
    CT
    Posts
    1,729

    SA250 down no or low power output

    SA 250 has lost output, Code 9023 w Perkins Diesel and auxillary AC. was having problems with it over last couple days. Normally when you start engine needle on Amp meter usually runs to near 400 . other day it did not move from a little more than 0. Then it started producing power like normal. Yesterday I had it on a job welding and it ran fine. I shut the machine down for lunch and later when I fired it it lost output again. Aux. power was very low but after pulling the trigger on my grinder a few times it seemed to excite and was OK again. Same thing end of day, but was unable to get it going again.
    Checked the brushes and all were free in holders , both aux. gen and main gen. noted the armature was dirty so I cleaned that and low and behold the power came back, however I did note, on start up the amp meter would hand out around 10 for maybe 3 seconds and then kick up high. Definitely not how it usually is. Anyway welding with it today it was fine, no indication of any problem but when I shut down, on restart it would not produce any power.
    checked so far, Engine alternator and diode seem to be fine with meter, brushes are all free, cleaned wire connections to brushes at slip rings, Also thought I would try to flash it to see if that would help, what I noticed was that when I touched the last lead to the positive brush holder I did not get the usual spark that I was expecting.
    I searched through the threads and some have had problems with the bridge rectifier. What else might I check. Thanks
    "Si Vis Pacem Para Bellum"

    Lincoln Idealarc 250 AC/DC
    Millermatic 251 Syncrowave 300 30A spoolgun
    Lincoln MP210
    Hypertherm 45
    (2) LN 25
    (2) Lincoln Weldanpower 225 CV
    (4) SA200 1 short hood SA250 SAM 400

  2. #2
    Join Date
    Apr 2006
    Location
    CT
    Posts
    1,729

    Re: SA250 down no or low power output

    Also checked the oil pressure switch, it seems to be OK.
    "Si Vis Pacem Para Bellum"

    Lincoln Idealarc 250 AC/DC
    Millermatic 251 Syncrowave 300 30A spoolgun
    Lincoln MP210
    Hypertherm 45
    (2) LN 25
    (2) Lincoln Weldanpower 225 CV
    (4) SA200 1 short hood SA250 SAM 400

  3. #3
    Join Date
    Apr 2006
    Location
    CT
    Posts
    1,729

    Re: SA250 down no or low power output

    Anybody?
    "Si Vis Pacem Para Bellum"

    Lincoln Idealarc 250 AC/DC
    Millermatic 251 Syncrowave 300 30A spoolgun
    Lincoln MP210
    Hypertherm 45
    (2) LN 25
    (2) Lincoln Weldanpower 225 CV
    (4) SA200 1 short hood SA250 SAM 400

  4. #4
    Join Date
    Apr 2006
    Location
    CT
    Posts
    1,729

    Re: SA250 down no or low power output

    Not 1 reply, I must have done something. For what it's worth, terminal corroded off bridge rectifier, replaced with a new 1 and good to go again.
    "Si Vis Pacem Para Bellum"

    Lincoln Idealarc 250 AC/DC
    Millermatic 251 Syncrowave 300 30A spoolgun
    Lincoln MP210
    Hypertherm 45
    (2) LN 25
    (2) Lincoln Weldanpower 225 CV
    (4) SA200 1 short hood SA250 SAM 400

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
RSS | Home | Penton Media | Contact Us | Subscribe | For Advertisers | Terms of Use | Privacy Statement