Results 1 to 6 of 6

Thread: Lincoln Outback 185 no power issues

  1. #1
    Join Date
    May 2017
    Posts
    2
    Post Thanks / Like

    Lincoln Outback 185 no power issues

    This is my first post so please bear with me. I have an Outback 185 that will not put out power. The technician changed out the circuit board and generator but still no juice. Any help is greatly appreciated.

  2. #2
    Join Date
    Apr 2017
    Posts
    138
    Post Thanks / Like

    Re: Lincoln Outback 185 no power issues

    The technician returned the welder to you not working ??????
    Did you request unit returned to you before complete repair done?
    Was this a Lincoln recognized repair center?
    A little more information required such as both A/C auxiliary and D/C weld both dead?

  3. #3
    Join Date
    May 2017
    Posts
    2
    Post Thanks / Like

    Re: Lincoln Outback 185 no power issues

    Quote Originally Posted by Dana gear View Post
    The technician returned the welder to you not working ??????
    Did you request unit returned to you before complete repair done?
    Was this a Lincoln recognized repair center?
    A little more information required such as both A/C auxiliary and D/C weld both dead?
    Dana gear thanks for replying. The technician called me saying that the welder was repaired...he started it and electrical outlets worked, to include connecting leads and welding scrap metal. I came by to get the machine and I wanted to see everything working before loading on my truck. The machine started perfectly but there was no electrical power to outlets or the leads. Well he said that it worked before so he did something to the generator by touching a negative and positive wire from the battery to the generator. He started again and machine worked...electrical power to outlets and leads. Well I accepted it and checked it again when I got home...NO POWER. When brought back the tech looked stumped as to what might be wrong with it. Going on two weeks and still waiting for a call back.

    The company is an authorized Lincoln distributor so I would imagine they would also be the repair center for Lincoln. I apologize for the long story but if I could at least get pointed in the right direction I would be very grateful.

    Thanks again Dana gear.

  4. #4
    Join Date
    May 2008
    Location
    Orange, TX
    Posts
    17,395
    Post Thanks / Like

    Re: Lincoln Outback 185 no power issues

    What is the unit Code# off the data tag. There are at least 3 possible Code#s and there may be slight differences from one to the others.

    From your description, the "technician" simply manually flashed the rotor field to kick it off. Shut it down and it won't re-excite by itself. Sounds as if the problem is in the initial start exciter circuit/components.
    Last edited by duaneb55; 06-21-2017 at 12:45 PM.
    MM200 w/Spoolmatic 1
    Syncrowave 180SD
    Bobcat 225G Plus - LP/NG
    MUTT Suitcase Wirefeeder
    WC-1S/Spoolmatic 1
    HF-251D-1
    PakMaster 100XL
    '68 Red Face Code #6633 project
    Star Jet 21-110

    Save Second Base!

  5. #5
    Join Date
    Feb 2019
    Posts
    4
    Post Thanks / Like

    Re: Lincoln Outback 185 no power issues

    I'm a welder repair technician, if the code on your machine is 11731 or 11825 there is a known issue, there is a relay in the machine that works in conjunction with the voltage regulator board, the relay fails to close providing the exciter voltage, there is a kit to repair this, it is part number S32031. To check if this is the issue move the leads on the top left of the relay (#6) down to #7, if the power comes up this is probably the issue.

    Don't leave the lead there or it will drain your battery

    I'm having a similar issue with a machine I'm working on, the power works intermittently, haven't got it resolved yet but will repost if/when I resolve the issue.
    Last edited by Service.CWS; 02-13-2019 at 07:27 PM.

  6. #6
    Join Date
    Sep 2020
    Posts
    3
    Post Thanks / Like

    Re: Lincoln Outback 185 no power issues

    Good afternoon Petergun were u ever to fix your machine? Ive a couple of 185 that are doing the same thing. Intermittent power or quickly lose power after a few mins of running. Engine is fine just aux and power on welding side

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Page generated in 1,603,163,043.97855 seconds with 13 queries