Results 1 to 4 of 4

Thread: TIG NooB w/ squarewave 275 Troubleshoot

  1. #1
    Join Date
    Jan 2019
    Posts
    3
    Post Thanks / Like

    TIG NooB w/ squarewave 275 Troubleshoot

    Hello, I aM cURTIS. I hve been an automotive tech for 10 plus years. I recently got commercial Diver certification and underwater welding. I decided to purchase a TIG/Stick welder to build up my skill while at home and not offshore.


    SO,

    I recently got my hands on a Lincoln Squarewave 275. code#10605

    When turn machine on I get buzz noise and that's it.
    Voltmeter and Ammeter both have no display functionality.

    I tested the T1 transformer(GOOD)
    tested inputs to PC Control Board(GOOD)

    I can see an ARC on the connections inside the polarity switch when change setting from AC to DC

    Guy I purchased from said the Control board was bad.

    But after extensive visual inspection I find nothing that would lead me to believe it is faulty.
    (I have a lot of circuit board inspection and repair experience)

    Name:  20190116_024736 - Copy.jpg
Views: 108
Size:  96.4 KB
    Name:  20190116_024750 - Copy.jpg
Views: 109
Size:  149.2 KB
    Name:  20190116_024819 - Copy.jpg
Views: 107
Size:  104.6 KB
    Name:  20190116_024809 - Copy.jpg
Views: 108
Size:  80.6 KB

  2. #2
    Join Date
    Jun 2012
    Location
    Sebeka and Bemidji MN
    Posts
    14,635
    Post Thanks / Like

    Re: TIG NooB w/ squarewave 275 Troubleshoot

    I'm not real familiar with the modern method of rectification, but on a transformer machine I would suspect a failed diode.

    The arc when changing the selector makes me think your problem is similar.

    Clamp your meter on a hot leg and see how much input current is being used. If more than just the idle current amount, I'd test the diodes or bridge rectifier, which ever you have.
    Last edited by MinnesotaDave; 01-16-2019 at 08:13 AM.
    Dave J.

    Beware of false knowledge; it is more dangerous than ignorance. ~George Bernard Shaw~

    Airco 300 - Syncro 350
    Invertec v250-s
    Thermal Arc 161 and 300
    MM210
    Dialarc
    Tried being normal once, didn't take....I think it was a Tuesday.

  3. #3
    Join Date
    Jan 2011
    Location
    Hutchinson Kansas
    Posts
    571
    Post Thanks / Like

    Re: TIG NooB w/ squarewave 275 Troubleshoot

    I have one of those. When you turn it on it does just what you say. When you strike the arc the fan will come on.
    I wonder if its just the display that quit. Flip the process switch down to stick set the amp dial to 11 o'clock position (about 100A) see if it will burn rods.
    Lincolin Power Wave 450, Lincoln Powermig 255, Lincoln Pro Mig 140, Lincoln Squarewave Tig 275, Miller Big 40 G(with Hobart Hefty suitcase), Thermal Arc 95S and Esab PCM875 in an already full machine shop.

  4. #4
    Join Date
    Jun 2017
    Location
    AJO, ARIZONA
    Posts
    3,430
    Post Thanks / Like

    Re: TIG NooB w/ squarewave 275 Troubleshoot

    Welcome!
    NRA LIFE MEMBER
    UNITWELD 175 AMP 3 IN1 DC MIG/STICK/TIG
    MIDSTATES 300 AMP AC MACHINE
    GOD BLESS AMERICA!
    “Freedom is never more than one generation away from extinction.
    We didn’t pass it to our children in the bloodstream".
    RONALD REAGAN

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Page generated in 1,606,202,113.11474 seconds with 14 queries