Results 1 to 3 of 3

Thread: Longevity Weld Max LC-416D stopped working

  1. #1
    Join Date
    May 2020
    Posts
    5
    Post Thanks / Like

    Longevity Weld Max LC-416D stopped working

    I have had the unit for several years and only used the plasma cutting function. Recently, I needed to use the stick welder on my tractor. I'm a complete beginner with stick. I managed to burn through half a rod before it died. I now get nothing to work. I was running the machine on a generator and stopped for a second to grind off one of my many mistakes. The grinder was also running off the same generator. The generator came under a heavier load for a few seconds as I was grinding. But did not trip any breakers. I went back to the Longevity and the display was blank. I tried every function and nothing worked. The translucent power button on the back is illuminated and I confirmed it was getting power with a multi-meter.

    Emailed Longevity for help and any documents they still have. I was told they could send the wiring diagram and I qualified for 15% off purchase of new unit. But otherwise, no help. Still have not received wiring diagram.

    I haven't found much information about this unit and I'm trying to figure out if I can repair it or just need to cut my losses.

    Thanks

  2. #2
    Join Date
    Aug 2009
    Posts
    21
    Post Thanks / Like

    Re: Longevity Weld Max LC-416D stopped working

    I have a 520D and my switch just died. I was getting power in but the contacts burned out. I suspect that if it's not something simple like the switch it's not worth spending the time to fix.

  3. #3
    Join Date
    Jul 2020
    Posts
    13
    Post Thanks / Like

    Re: Longevity Weld Max LC-416D stopped working

    Quote Originally Posted by mightymeatman View Post
    I have had the unit for several years and only used the plasma cutting function. Recently, I needed to use the stick welder on my tractor. I'm a complete beginner with stick. I managed to burn through half a rod before it died. I now get nothing to work. I was running the machine on a generator and stopped for a second to grind off one of my many mistakes. The grinder was also running off the same generator. The generator came under a heavier load for a few seconds as I was grinding. But did not trip any breakers. I went back to the Longevity and the display was blank. I tried every function and nothing worked. The translucent power button on the back is illuminated and I confirmed it was getting power with a multi-meter.

    Emailed Longevity for help and any documents they still have. I was told they could send the wiring diagram and I qualified for 15% off purchase of new unit. But otherwise, no help. Still have not received wiring diagram.

    I haven't found much information about this unit and I'm trying to figure out if I can repair it or just need to cut my losses.

    Thanks
    Probably the downtime of your work and the cost of repairing the machine, will be commensurate with the purchase of a new device.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Page generated in 1,611,056,436.33359 seconds with 13 queries