Results 1 to 2 of 2

Thread: Hobart Tigwave 250 no AC output

  1. #1
    Join Date
    Jun 2020
    Posts
    2
    Post Thanks / Like

    Hobart Tigwave 250 no AC output

    I've got an old (mid 90's) Hobart Tigwave 250 at work that's giving me grief, I greatly prefer it over the prehistoric Miller we have, but it doesn't function with the selector handle in AC. I remember it used to work, then the whole machine quit. It was repaired and I only ever used it on DC. One day I set up to weld some aluminum, swithed it over to AC, and pretty much nothing happened. If I set it to stick and crank the amperage way up I can get a little arc out of it, but nothing else.

    Is there anything specifically that I should be checking? Have a operator's manual, but that's about it.

    Thanks for any help you can offer.

    Gary

  2. #2
    Join Date
    Sep 2016
    Location
    Detroit, Michigan
    Posts
    399
    Post Thanks / Like

    Re: Hobart Tigwave 250 no AC output

    There's a thread I started that might give you a few things to try:

    https://weldingweb.com/vbb/showthrea...98#post8747498
    Check out my bench vise website:
    http://mivise.com


    Miller Syncrowave 250DX
    Millermatic 252 W/Spoolmatic 30A
    Miller Dialarc 250
    Hobart Champion Elite
    Everlast PowerTig 210EXT

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Page generated in 1,603,386,641.23542 seconds with 13 queries