Results 1 to 15 of 15

Thread: Hobart Champion 10,000 won't weld

  1. #1
    Join Date
    Mar 2012
    Posts
    6
    Post Thanks / Like

    Hobart Champion 10,000 won't weld

    Hello, Asked about this machine some time ago but didn't have the serial number. Got it home now so here goes again. Generates auxillary power but will only start a small bead for a few seconds no matter what the setting. Have no idea where to start diagnosing so would really appreciate your input. Serial #LB282301 and stock #500433. Thanks in advance. Mike

  2. #2
    Join Date
    May 2010
    Location
    ct.
    Posts
    1,381
    Post Thanks / Like

    Re: Hobart Champion 10,000 won't weld

    Is this a DC only or an AC/DC machine?
    Miller a/c-d/c Thunderbolt XL
    Millermatic 180
    Purox O/A
    Smith Littletorch O/A
    Hobart Champion Elite

  3. #3
    Join Date
    May 2008
    Location
    Orange, TX
    Posts
    17,392
    Post Thanks / Like

    Re: Hobart Champion 10,000 won't weld

    DC only machine.

    Could be failed weld output rectifier diode(s), open weld stator winding or a couple other things.

    PM me an email address and I'll send you some troubleshooting information that is too large to post on the forum.
    MM200 w/Spoolmatic 1
    Syncrowave 180SD
    Bobcat 225G Plus - LP/NG
    MUTT Suitcase Wirefeeder
    WC-1S/Spoolmatic 1
    HF-251D-1
    PakMaster 100XL
    '68 Red Face Code #6633 project
    Star Jet 21-110

    Save Second Base!

  4. #4
    Join Date
    May 2010
    Location
    ct.
    Posts
    1,381
    Post Thanks / Like

    Re: Hobart Champion 10,000 won't weld

    This thread caught my attention as I JUST bought a
    Champion Elite.(11kw peak,DC only weld).
    Curious what failed in OP’s machine.
    Miller a/c-d/c Thunderbolt XL
    Millermatic 180
    Purox O/A
    Smith Littletorch O/A
    Hobart Champion Elite

  5. #5
    Join Date
    Mar 2012
    Posts
    6
    Post Thanks / Like

    Re: Hobart Champion 10,000 won't weld

    I think I sent a PM with my email? If you don't get it please let me know! Thanks.

  6. #6
    Join Date
    Mar 2012
    Posts
    6
    Post Thanks / Like

    Re: Hobart Champion 10,000 won't weld

    Haven't gotten very far but so far it's blowing fuse F1 immediately every time if that gives any clues.

  7. #7
    Join Date
    May 2010
    Location
    ct.
    Posts
    1,381
    Post Thanks / Like

    Re: Hobart Champion 10,000 won't weld

    Have you checked rectifier bridge for a shorted rectifier?
    Does your machine have a field control board?
    Miller a/c-d/c Thunderbolt XL
    Millermatic 180
    Purox O/A
    Smith Littletorch O/A
    Hobart Champion Elite

  8. #8
    Join Date
    May 2008
    Location
    Orange, TX
    Posts
    17,392
    Post Thanks / Like

    Re: Hobart Champion 10,000 won't weld

    Quote Originally Posted by odiie View Post
    I think I sent a PM with my email? If you don't get it please let me know! Thanks.
    Yes I did. Did you get my email?
    MM200 w/Spoolmatic 1
    Syncrowave 180SD
    Bobcat 225G Plus - LP/NG
    MUTT Suitcase Wirefeeder
    WC-1S/Spoolmatic 1
    HF-251D-1
    PakMaster 100XL
    '68 Red Face Code #6633 project
    Star Jet 21-110

    Save Second Base!

  9. #9
    Join Date
    May 2008
    Location
    Orange, TX
    Posts
    17,392
    Post Thanks / Like

    Re: Hobart Champion 10,000 won't weld

    Quote Originally Posted by odiie View Post
    Haven't gotten very far but so far it's blowing fuse F1 immediately every time if that gives any clues.
    A blowing fuse F1 typically indicates a shorted bridge rectifier SR2. Start there.
    MM200 w/Spoolmatic 1
    Syncrowave 180SD
    Bobcat 225G Plus - LP/NG
    MUTT Suitcase Wirefeeder
    WC-1S/Spoolmatic 1
    HF-251D-1
    PakMaster 100XL
    '68 Red Face Code #6633 project
    Star Jet 21-110

    Save Second Base!

  10. #10
    Join Date
    Mar 2012
    Posts
    6
    Post Thanks / Like

    Re: Hobart Champion 10,000 won't weld

    Progress has been slow. I did check the bridge rectifier and it tests ok. However, the rotor calls for 18 ohms and it's reading 4. Is this likely my cause for blowing F1 fuse? If so, how costly is a rotor? I'm debating using the engine as a donor in a skid steer so either way I can't really lose.

  11. #11
    Join Date
    Sep 2018
    Posts
    2
    Post Thanks / Like

    Re: Hobart Champion 10,000 won't weld

    Just purchased a used Hobart champion 10000 F1 fuse is blown. Previous owner stated machine was working stopped for lunch now will not weld an no AC power to the outlets. How do you test the bridge rectifier an is this a common failed part?

  12. #12
    Join Date
    May 2008
    Location
    Orange, TX
    Posts
    17,392
    Post Thanks / Like

    Re: Hobart Champion 10,000 won't weld

    MM200 w/Spoolmatic 1
    Syncrowave 180SD
    Bobcat 225G Plus - LP/NG
    MUTT Suitcase Wirefeeder
    WC-1S/Spoolmatic 1
    HF-251D-1
    PakMaster 100XL
    '68 Red Face Code #6633 project
    Star Jet 21-110

    Save Second Base!

  13. #13
    Join Date
    May 2008
    Location
    Orange, TX
    Posts
    17,392
    Post Thanks / Like

    Re: Hobart Champion 10,000 won't weld

    The Champion has also been known to have control board failures but start with the bridge rectifier.
    MM200 w/Spoolmatic 1
    Syncrowave 180SD
    Bobcat 225G Plus - LP/NG
    MUTT Suitcase Wirefeeder
    WC-1S/Spoolmatic 1
    HF-251D-1
    PakMaster 100XL
    '68 Red Face Code #6633 project
    Star Jet 21-110

    Save Second Base!

  14. #14
    Join Date
    Sep 2018
    Posts
    2
    Post Thanks / Like

    Re: Hobart Champion 10,000 won't weld

    Quote Originally Posted by duaneb55 View Post
    Thank you for the pdf file on testing the rectifier. I have not pulled the cover to access the part. I did replace the fuse an started the welder, I tried an angel grinder at both AC receptacles the grinder did not run but the engine revved up each time the grinder switch was pulled i shut the unit off an checked the F1 fuse an it was not blown.

  15. #15
    Join Date
    Mar 2021
    Posts
    8
    Post Thanks / Like

    Re: Hobart Champion 10,000 won't weld

    If this thread is still going I have the same problem with my 10,000. When you start it it has power for a few seconds then the red light on the board lights up and it loses power. I have been messing with it off and on for a long time so I decided to get some help from people who know what they are doing.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Page generated in 1,632,821,989.48714 seconds with 12 queries