Results 1 to 3 of 3

Thread: TB 301G repair question

  1. #1
    Join Date
    Mar 2008
    Location
    Georgetown, Texas
    Posts
    1,961
    Post Thanks / Like

    TB 301G repair question

    My TB won't crank and I'm having trouble figuring it out. I have 12V through the switch but not back to the solenoid. After the wire goes through a plug in the mid frame chassis, there is 2 wires and the wire that doesn't go to the solenoid has a "thing" in the wire. I think it's a diode but can't figure out where that wire goes or if it is the problem. Any one have any suggestions? I'm only about half *** at this kind of thing.

  2. #2
    Join Date
    May 2010
    Location
    ct.
    Posts
    1,335
    Post Thanks / Like

    Re: TB 301G repair question

    Have you checked plug connections?
    Looks like the only thing between the start terminal of the switch
    and the coil terminal of the starter solenoid is plug PLG5. Diode
    branches off to bypass the low oil pressure shutdown and shouldn’t
    affect cranking.
    Miller a/c-d/c Thunderbolt XL
    Millermatic 180
    Purox O/A
    Smith Littletorch O/A
    Hobart Champion Elite

  3. #3
    Join Date
    Mar 2008
    Location
    Georgetown, Texas
    Posts
    1,961
    Post Thanks / Like

    Re: TB 301G repair question

    Thanks, I finally figured it out. The wire harness plug that is at the cross frame was corroded.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Page generated in 1,624,027,043.35935 seconds with 11 queries