Results 1 to 3 of 3

Thread: Starter question on a Black face/green light

  1. #1
    Join Date
    Nov 2012
    Location
    North Port Florida
    Posts
    82
    Post Thanks / Like

    Starter question on a Black face/green light

    This is my first SA 200, this one I just bought and hadn't run in 8 years. I put a new battery in there just to rotate the engine (no spark plugs). Green light comes on when hitting the starter, but the starter works with the ignition on and OFF. Is this normal?
    It seemed like a good idea at the time!

  2. #2
    Join Date
    May 2014
    Location
    Central Wa. state
    Posts
    4,631
    Post Thanks / Like

    Re: Starter question on a Black face/green light

    Quote Originally Posted by welding1 View Post
    This is my first SA 200, this one I just bought and hadn't run in 8 years. I put a new battery in there just to rotate the engine (no spark plugs). Green light comes on when hitting the starter, but the starter works with the ignition on and OFF. Is this normal?

    If you have magneto ignition, all the switch does is short the mag to kill the engine. Oil pressure switch controls every thing else.

  3. #3
    Join Date
    Nov 2012
    Location
    North Port Florida
    Posts
    82
    Post Thanks / Like

    Re: Starter question on a Black face/green light

    I have a Prestolite distributor. Next few days ill put on the radiator and a box full of parts from BW parts and run it.
    It seemed like a good idea at the time!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Page generated in 1,624,108,159.50623 seconds with 11 queries