Results 1 to 3 of 3

Thread: Miller Trailblazer 302 Troubleshooting

  1. #1
    Join Date
    Aug 2018
    Posts
    9
    Post Thanks / Like

    Miller Trailblazer 302 Troubleshooting

    Hello All: looking for help troubleshooting a Miller Trailblazer 302 with a Kohler gas engine. The engine is a CH20S made in 2005. Unit has been recently service, oil change, filters, etc..The unit started and was running as it should and then just died. When I tried to restart, the unit will crank but not start. Full of gas. I tried starting fluid and nothing. I am going to keep looking this morning and will check to see if I have spark at the plugs. Any other thoughts on where I should begin looking for potential issues is appreciated.

    UPDATE on my post this morning...so it does start and run after it cools off, however, it runs for about 2 or 3 minutes and then starts slowing dying as if its starving for fuel. I am going to check fuel filter and the fuel solenoid....any other thoughts?. Many thanks
    Pudgey
    Last edited by pudgey; 12-27-2019 at 11:04 AM. Reason: sp and updated

  2. #2
    Join Date
    Apr 2012
    Location
    NW OR
    Posts
    132
    Post Thanks / Like

    Re: Miller Trailblazer 302 Troubleshooting

    Did you try with the gas cap off?

  3. #3
    Join Date
    Aug 2018
    Posts
    9
    Post Thanks / Like

    Re: Miller Trailblazer 302 Troubleshooting

    Quote Originally Posted by gtermini View Post
    Did you try with the gas cap off?
    Yes I did and it started and ran like it should have...many thanks!

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Page generated in 1,634,857,929.88966 seconds with 11 queries