Page 2 of 2 FirstFirst 12
Results 26 to 28 of 28

Thread: The old Cut 'N Etch don't lie!

  1. #26
    Join Date
    Jul 2018
    Location
    Cumbria, UK
    Posts
    1,337
    Post Thanks / Like

    Re: The old Cut 'N Etch don't lie!

    A mid mount PTO? I've never seen one of those before... quite interested to see more pics, especially of the finished work... pretty cool work.

    Not too impressed with the downhill MIG (this is a no-no) but for what it is I'm sure the frame will work just fine
    Murphy's Golden Rule: Whoever has the gold, makes the rules.

  2. #27
    Join Date
    Jan 2011
    Location
    W. Wisc
    Posts
    575
    Post Thanks / Like

    Re: The old Cut 'N Etch don't lie!

    I did actually bevel those butt joints a little, but probably not enough. Everything was welded flat (or overhead, in a couple cases) as I have never been able to make a vertical weld with MIG without it running and dripping like mad. Like i said, they weren't all good, but overall it was much improved...
    -Dave
    XMT304 with: 22A Feeder, or HF251 Hi Freq DC TIG air cooled

  3. #28
    Join Date
    Feb 2010
    Location
    Bandera,TX / MN
    Posts
    726
    Post Thanks / Like

    Re: The old Cut 'N Etch don't lie!

    Dave it requires two settings for the vee groove butt as opposed to the fillet weld. That being said I tend to turn up the machine and push the vee groove and pull the fillet. Works OK for me. Your tig looks pretty damn good! Will be heading up the end of May after the snow danger is over!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Page generated in 1,624,270,978.95461 seconds with 11 queries