Results 1 to 2 of 2

Thread: Hobart TR-250-HF Low Voltage

Hybrid View

Previous Post Previous Post   Next Post Next Post
  1. #1
    Join Date
    Jun 2021
    Posts
    3
    Post Thanks / Like

    Hobart TR-250-HF Low Voltage

    Hello,

    I have a Hobart TR-250HF, serial #:80WS06308. I was welding some aluminum the other day when the arc got really small like someone cut the power by 90%. I replaced the tungsten tip, made sure the ground clamp was clean and making good contact, checked the incoming voltage - which was 120v each leg, 240v across both power legs, and the ground wire was working properly. As an example, the aluminum I'm welding is .100, and to finish the project, I had to turn the power output to high and it barely had the juice to get a puddle going. I could normally weld .500 thick aluminum at that setting.

    Since then, I tried the machine on full power with stick feed to steel, and still a no go. It has spark, but it's so weak I'm not sure if it would weld a tin can together.

    As mentioned above, I checked the incoming voltage at the wall connection, but I'm not sure how to check for other machine voltages.

    This is a Hobart Model TR-250HF, Spec: 6088-1, Serial: 80WS06308. My dad bought this welder new sometime in the mid '70's, and I have it now. To my knowledge, he never had any problems with it until this issue.

    Any advise or help you could possibly provide regarding things to check or how to check, would be greatly appreciated.

    Thank you, Eric

  2. #2
    Join Date
    Mar 2010
    Location
    Ceres, California
    Posts
    3,904
    Post Thanks / Like

    Re: Hobart TR-250-HF Low Voltage

    Sounds like the Mag amp power supply is failing. Module on the center bracket.
    Check the fuse and resisters. Search this site for old threads on on this welder.
    there are several.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Page generated in 1,638,058,511.12281 seconds with 11 queries