Results 1 to 2 of 2

Thread: Lincoln powermig 255 problems

  1. #1
    Join Date
    Jan 2009
    Location
    kewanee, Mo
    Posts
    97
    Post Thanks / Like

    Lincoln powermig 255 problems

    Have a powermig 255 that the volts wonít go down. You can turn the knob and the digital display shows the volts going up or down but when you weld it is like they are all the way up. Sometimes it will weld normal or like they are all the way down but most of the time it is hot. Have put a new pot on it just because it was cheap to try but didnít change anything.
    Equipment:
    Lincoln Ranger 8
    Lincoln Power Mig 255
    Miller Diversion 165
    Hypertherm Powermax 45
    Victor Pro Series Torch set
    Tons of other shop supplies

  2. #2
    Join Date
    Mar 2010
    Location
    Ceres, California
    Posts
    3,909
    Post Thanks / Like

    Re: Lincoln powermig 255 problems

    Since is does work once and a while. You might just have a loose connection in the feed back circuits. either the wires from the shunt or the voltage wires from the output studs. Get the diagram from the owner's manual or the one pasted on the side panel. find wires 205 and 206S they come from the current shunt. diagram shows it as a box just above the output choke. wires 206 and 207 are your voltage feed back to the control pcb. Check wires for cuts and damaged insulation. then check connections to shunt and weld terminal. Then look at plug to control pcb.
    Look into the plug connections and make sure the hole is not larger then the other ones. If all connections to the pcb check out OK. then pcb may be bad.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Page generated in 1,638,109,201.74765 seconds with 11 queries