Results 1 to 6 of 6

Thread: Lincoln SA 250 No power

  1. #1
    Join Date
    Oct 2021
    Posts
    4
    Post Thanks / Like

    Lincoln SA 250 No power

    So I’ve got an old SA 250 Perkins.

    She sat sat for a few years, got it fired up, engine runs but no power weld or accessory.

    Also noticed when I reconnected the battery, that the hour meter continuously runs even with the machine off.

    Tried flashing the field coils per the manual. The main fuse had the terminal corroded off, fixed that…. Still no power.

    Any recommendations?

  2. #2
    Join Date
    Nov 2012
    Location
    ROCKVILLE ,,VA
    Posts
    483
    Post Thanks / Like

    Re: Lincoln SA 250 No power

    guessing you clean/stone armature? oil pressure switch bad with hour meter running.. few years ago took chance bought one the motor that ran good but didn't weld or produce power ,, starting cleaning dirty connection,, Right where two small wires from rheostat goes into weld barrel there was break in one two wires do vibration couldn't see the break in wire until tug on it , and broke repair wire was good to go,, guess why most people call them rattle boxes!!great machine , got one now with supposed to have 10,000 hours

  3. #3
    Join Date
    Oct 2021
    Posts
    4
    Post Thanks / Like

    Re: Lincoln SA 250 No power

    Yes cleaned armatures with stone.

    Have a 15-20 volt AC at the auxiliary plugs.

    Rheostat - Found a range from 10-64 ohms. BUT full min and max reads open??

    Brushes at the exciter show minor evidence of arc damage (few small pits on brush) slip ring looks fine.

    Exciter diode tested good. Wires from rheostat into generator seem good no Visible issues.

    What should I test next?

  4. #4
    Join Date
    Oct 2021
    Posts
    4
    Post Thanks / Like

    Re: Lincoln SA 250 No power

    Any ideas?

  5. #5
    Join Date
    Oct 2021
    Posts
    4
    Post Thanks / Like

    Re: Lincoln SA 250 No power

    Mic check

    would appreciate some help fellas.

  6. #6
    Join Date
    May 2021
    Location
    NW Georgia
    Posts
    15
    Post Thanks / Like

    Re: Lincoln SA 250 No power

    Did you do 'Alternator Rotor Test' ?

    Does the auxiliary voltage vary with the adjustment of the rheostat?
    Last edited by DD-YATES; 4 Weeks Ago at 03:04 PM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Page generated in 1,638,758,873.29385 seconds with 11 queries