Results 1 to 4 of 4

Thread: ForceCut 60i plasma cutter

  1. #1
    Join Date
    Jan 2022
    Posts
    2
    Post Thanks / Like

    ForceCut 60i plasma cutter

    I have an old plasma cutter ForceCut 60i, and the torch only makes a small spark from the work approximately 3/8" long and never starts to cut. The machine Starts up, blows air from torch, but wont cut. The inside of torch were the electrode screws in the center looks burnt. Any help?? Also the ceramic cup i got is to Big, need correct part number please.

  2. #2
    Join Date
    Dec 2013
    Posts
    1,912
    Post Thanks / Like

    Re: ForceCut 60i plasma cutter

    Do your consumables look like the ones at the bottom of this page?
    https://www.longevity-inc.com/forcecut-60i
    ---Meltedmetal

  3. #3
    Join Date
    Jan 2022
    Posts
    2
    Post Thanks / Like

    Re: ForceCut 60i plasma cutter

    Yes they do. But the pink cup is to big to screw on torch head.Name:  20220111_124139.jpg
Views: 30
Size:  83.9 KBName:  20220111_124139.jpg
Views: 30
Size:  83.9 KB
    Last edited by Herbert Feltman; 1 Week Ago at 02:57 PM. Reason: show bad part.

  4. #4
    Join Date
    Dec 2021
    Location
    Canada
    Posts
    36
    Post Thanks / Like

    Re: ForceCut 60i plasma cutter

    Quote Originally Posted by Herbert Feltman View Post
    I have an old plasma cutter ForceCut 60i, and the torch only makes a small spark from the work approximately 3/8" long and never starts to cut. The machine Starts up, blows air from torch, but wont cut. The inside of torch were the electrode screws in the center looks burnt. Any help?? Also the ceramic cup i got is to Big, need correct part number please.

    Water in air?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Page generated in 1,642,624,952.35709 seconds with 13 queries